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Most of us have had the unpleasant experience of sharing information we later wished we
hadn’t. We all (or most of us...) like to help other researchers when we can, especially
nice ones who show signs of basic intelligence, but eventually every genealogist learns
that sharing information about living people can lead to mental anguish (or possibly legal
action). We may not want to publish information about family skeletons, no matter how
old. Sometimes, too, we prefer not to share information that we have not yet proven,
especially with someone who is likely to splash it all over the internet. Or we simply do
not want to give more than the bare bones to a researcher who is unlikely to reciprocate
with information. In general, we all have different categories of people with whom we
share, and we want to tailor what we share according to the recipient.

The TMG programmers are well aware of these issues, and have provided no fewer than
SEVEN ways of excluding certain information from reports, GEDCOMs, or the
computer screen.
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1. Single exclusion marker

One way to exclude information from a report —for example, you want all the information
from a death tag to show except for the cause of death—is to enter a single hyphen as the
first character in a field, and it will suppress the printing of the information entered in the
rest of the field. It can also be entered at the beginning of a tag’s sentence structure to
suppress the printing of the entire sentence. In other words, a single exclusion marker at
the beginning of a sentence field in any tag, or at the beginning of the memo field in a
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note tag, prevents the printing of that tag and the export of that entire tag to GEDCOM (if
“Show excluded data” is not checked in the report options). An exclusion marker at the
beginning of the memo field in any non-note tag prevents the printing of that tag's memo
and the export of that memo to GEDCOM (again, if “Show excluded data” is not
checked).

You can also use them when you have a source note but do not want a bibliography
entry—just put a hyphen in the bibliography field of the source definition screen.
Accordingly, you can use the single exclusion marker in any of the following places:

- in any field of any tag (except the date field, which seems a little weird; if you put one
in, the date changes from, say, 23 June 1870 to “before 23 June 1870”; the same is true
for the double exclusion marker);

- in the memo field of any tag;

- in the sentence field of any tag;

- in a source citation field (full footnote, short footnote, and bibliography).

- in repository fields. When [REPOSITORY], [REPOSITORY ADDRESS], or
[REPOSITORY INFO] is used in a template, any repository fields with single exclusion
markers will preview with the markers showing, but will not print out unless “show
excluded data” is checked. (I use this a lot, since | like to have the whole address, zip
code, phone number, etc. of a courthouse or other repository available, but don’t want it
all to print out in my footnotes or bibliography).

When there are two principals in an event, a principal may be excluded from display in
the other principal's Person View if a single exclusion marker is typed before his or her
ID number. Either or both principals may be so marked. However, principals so marked
will still print out in reports. I’m not sure what the point of this is.....Basically, when you
use the single exclusion marker in a field, the data will still be visible in the Tag Entry
screen, but the information in that field will not show up in the person view, unless you
set File> Preferences> Tag Box > Show excluded data.
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This data will not print in a report or chart unless you set Report Options > Miscellaneous
tab > Show excluded data or Chart Options > Other tab > Show excluded data.

A single exclusion marker before the source number on the Citation screen will prevent a
source from printing unless Show excluded data is checked in the report options. (Of
course, you can also prevent the citation detail field from printing by checking Report
Options > Sources > Suppress citation details.) A rather cool feature is that exclusion
marks can be added to or removed from citations on the Tag Entry screen without
opening the citations window. To exclude a citation, just right-click on the citation in the
citation window and select “Exclude this citation.” To remove the exclusion marker,
right-click on the citation in the citation window again—you will note that “Exclude this
citation” in the menu has a check mark next to it. Click on it, and the check mark and the
exclusion marker will disappear.
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2. Double exclusion marker

The double exclusion marker is much like the single exclusion marker except that it is a
DOUBLE hyphen and it cannot be over-ridden with the “show excluded data” to show
the data on the screen, in reports and charts, or in GEDCOM files. Fields marked with
this symbol in name and event tags will not be included on the Person View (although
they will be visible in the Tag Entry screen), in reports, charts, or GEDCOM export files.
Double exclusion markers cannot be overridden by the “Show excluded data” option,
either in File > Preferences > Program Options: Tag Box or in individual reports. They
must be changed in the field itself. The Full footnote, Short footnote, and Bibliography
template fields on the Output form tab of the Source Definition screen also support the
double exclusion marker, and so, apparently, do the repository fields. A template so
marked does not show when previewed nor does it print. An interesting (or irritating) bug
reported on the TMG list is that a custom source type that has a bibliography template
with source elements but whose full footnote, and short footnote templates consist of only
the double exclusion marker does print. You get both a footnote reference printed in the
text, and you get a footnote entry printed, although the entry consists of only the
reference number and a period. If this worked the way it ought to, you would be able to
generate a bibliography entry without a footnote.



3. Sensitivity brackets { }

Placing curly brackets { } around the information you want to keep private will hide it on
the computer screen and prevent it from printing in reports. These brackets work within a
field to isolate specific words or phrases, and they cannot be over-ridden for onscreen
viewing. Such information will not be displayed on the Person View but will be visible
when you enter the Tag Entry screen. Printing suppression can be over-ridden by
selecting Show sensitive data in the chart or report options.
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4. Hidden text

Hidden text may be inserted into any memo or sentence field. To insert an embedded
code for hidden text into any memo type field (specifically in the tag entry screen memo
field, sentence structures, or citation; and in the memo fields in the supplemental and
output form tabs in source definition), highlight the relevant text, right-click, and select
the code from the menu. This has the same effect as sensitivity brackets, except that it can
never be over-ridden. The advantage of this is that there is no need to remember to check
the appropriate options on report definitions, so you never run the risk of revealing a
terrible secret by accident....(To see the text without the codes you have embedded,
right-click and select “Show No Codes”).
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5. Source surety levels for printing

Another way to control what information shows in a report is by using the surety levels as
a filter. This method only affects what prints out in a report or chart. Using Print
Options> General > Surety, you can tell the program to print only tags with a surety of 2
or above, for example; anything below that, or with no surety checked, will not print.
(You have the same option in the GEDCOM export menu.) Of course, to use this you
have to have been inputting surety values. And being somewhat consistent. Oops, too
late....
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Interesting note: Since embedded source citations apply to an indeterminate amount of
free-form text, they are not affected by any surety threshold that might be in effect for the
report. That is, the event memo and the embedded citation will be printed even if the
surety value in the embedded citation does not meet the surety threshold for the report. Is
this getting too complicated?




6. Living People feature

TMG also has a “Living People” feature that will prevent any information for people
whose LIVING flag is set to Y (Yes) from printing in reports or appearing in GEDCOMs.
The LIVING flag is automatically set to N (No) if (1) a death or burial has been entered
or (2) 110 years have passed since the birth date (the number 110 is set in Preferences >
Current project > Advanced > Assumed maximum lifespan; you can change it to a higher
or lower number). To avoid printing details for living people, select Report Options >
Miscellaneous > Suppress details for living people; or Chart Options > Other > Suppress
details for living people, or the miscellaneous options menu in the GEDCOM export
wizard. This will suppress all tags except the primary name.
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Family Group Sheet

Subject* | Joe Edward Grenzeback
Birth® 22 Jun 1922 Twin Falls, 10.
himiaga™ 4 Jul 1950 Sacramento, Califomia.
Death™ 28 by 1968 Los Angeles, Califomia.
hmage™ _ __ Jean Sulivan
Bunial® “witterans hemonal Cemetery, Los Angeles, Califomia.

Father® James Henry Grenzeback (b. 16 Dec 1579, d. 9 Feb 1958)
Mather™ Cora hclaren (b. 16 hiar 1890, d. 22 Apr 1975)
Spouse* Jeanne Adeline Rileyis stil living

Father™  Paul Wiram Riley (b, 13 Jun 1226, d. 26 gy 10530
hbther™  Adeline lsabel Exline (b. 18 Aug 1882, 4. 16 Feb 1976)

Three Children

M | lan McLaren Grenzeback is sl living

F | lMartha Isabel Grenzebackis still living

Daughter: Leah Hamik: is still living
Diaughtar: DOana Hamik iz =till living
Daughter: Moa Hamik is =till living

F |Ju|iana Harclerode Grenzebackis sl living




7. Using the split memo

Sometimes you may want to prevent only part of a tag from printing. In that case you can
do a couple of different things. You can split the memo field and enter the sensitive data
in @ memo partition that is not included in the sentence structure. For example, you might

have the sentence: [:CR:][P+] died <[M]> <[D]> <[L]> <[A]>. Then you put TWO fields
in the memo.
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suicide by going outside
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year.®
Bwira bl. Bolton died of consumption on 2 Feb 1877 at Brockville, Leeds Co., Ontario, Canada.®
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There. No indiscreet details.

You could also just delete the memo from the sentence structure altogether, and the
memo won’t print at all (but keep in mind that the rest of the sentence will, so make sure
it is not an integral part of the sentence).

A possibly better way to do the same thing without messing around with your sentence
structure every time you have something you want to hide is simply to use the exclusion
marker in the second (or other) memo field.

Here is my usual death sentence:

[:CR:][P+] died <[M]> <[D]> <[L]> <[A]>. <[M2]>
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Elvira M. Bolton died of consumption on 2 Feb 1877 at Brockville, Leeds Co., Ontario, Canada.?
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Printed on: 15 Feb 2007

Same results! But here is what you get if you remove the exclusion marker:

EEIwra M. Bolton died of consumption on 2 Feb 1877 at Brockville, Leeds Co., Ontario, Canada. Although the unofficial version is that she committed
suicide by going outside with wet hair.?

As usual, there are many ways to do most things in TMG.



